互亿无线 · 文档中心

短信验证码/通知 - 代码示例


易语言代码示例

.版本 2
.支持库 iconv
.支持库 EXMLParser
 
.程序集 窗口程序集_启动窗口
 
.子程序 __启动窗口_创建完毕
 
 
 
.子程序 账户信息判断, 逻辑型, 公开
 
.如果真 (接口名.内容 = "")
    信息框 ("请输入用户名", 0, )
    返回 (假)
.如果真结束
.如果真 (接口密.内容 = "")
    信息框 ("请输入密码", 0, )
    返回 (假)
.如果真结束
返回 (真)
 
.子程序 发送数据判断, 逻辑型, 公开
 
.如果真 (手机号.内容 = "")
    信息框 ("请输入手机号码", 0, )
    返回 (假)
.如果真结束
.如果真 (短信内容.内容 = "")
    信息框 ("请输入要发送的内容", 0, )
    返回 (假)
.如果真结束
返回 (真)
 
 
.子程序 _按钮1_被单击
.局部变量 节点名数组, 文本型, , "0"
.局部变量 子节点数, 整数型
.局部变量 i, 整数型
 
.如果真 (取反 (账户信息判断 ()))
    返回 ()
.如果真结束
.如果真 (取反 (发送数据判断 ()))
    返回 ()
.如果真结束
状态标签.标题 = 短信发送 (接口名.内容, 接口密.内容, 手机号.内容, 短信内容.内容)
xml文件名 = 取当前目录 () + "\data\submit.xml"
状态标签.标题 = 到文本 (编码转换 (到字节集 (状态标签.标题), #编码_UTF_8, #编码_GBK, ))
写到文件 (xml文件名, 到字节集 (状态标签.标题))
xml.导入 (xml文件名)
xml.取根节点名 (根节点)
xml.取子节点数 (根节点, 子节点数)
.如果真 (子节点数 > 0)
    xml.取子节点名 (根节点, 节点名数组)
    输出调试文本 (节点名数组 [1])
    输出调试文本 (节点名数组 [2])
    输出调试文本 (节点名数组 [3])
    输出调试文本 (xml.取节点值文本 (根节点 + "/code", ))
    输出调试文本 (xml.取节点值文本 (根节点 + "/msg", ))
    输出调试文本 (xml.取节点值文本 (根节点 + "/smsid", ))
    状态标签.标题 = "状态码:" + xml.取节点值文本 (根节点 + "/code", ) + #换行符 + "描述:" + xml.取节点值文本 (根节点 + "/msg", ) + #换行符 + "流水号:" + xml.取节点值文本 (根节点 + "/smsid", )
.如果真结束
xml.释放 ()
返回 ()
 
 
返回 ()
 
.子程序 _按钮2_被单击
.局部变量 节点名数组, 文本型, , "0"
.局部变量 子节点数, 整数型
.局部变量 i, 整数型
 
.如果真 (取反 (账户信息判断 ()))
    返回 ()
.如果真结束
 
状态标签.标题 = 剩余条数 (接口名.内容, 接口密.内容)
xml文件名 = 取当前目录 () + "\data\getnum.xml"
状态标签.标题 = 到文本 (编码转换 (到字节集 (状态标签.标题), #编码_UTF_8, #编码_GBK, ))
写到文件 (xml文件名, 到字节集 (状态标签.标题))
xml.导入 (xml文件名)
xml.取根节点名 (根节点)
xml.取子节点数 (根节点, 子节点数)
.如果真 (子节点数 > 0)
    xml.取子节点名 (根节点, 节点名数组)
    输出调试文本 (节点名数组 [1])
    输出调试文本 (节点名数组 [2])
    输出调试文本 (节点名数组 [3])
    输出调试文本 (xml.取节点值文本 (根节点 + "/code", ))
    输出调试文本 (xml.取节点值文本 (根节点 + "/msg", ))
    输出调试文本 (xml.取节点值文本 (根节点 + "/num", ))
    状态标签.标题 = "状态码:" + xml.取节点值文本 (根节点 + "/code", ) + #换行符 + "描述:" + xml.取节点值文本 (根节点 + "/msg", ) + #换行符 + "条数:" + xml.取节点值文本 (根节点 + "/num", )
.如果真结束
xml.释放 ()
返回 ()
 
 
.子程序 GBK编码转换, 文本型, 公开, 将一个GBK编码的文本转换为URL编码,返回一个URL编码
.参数 文本, 文本型, , 需要转换为URL编码的GBK编码的文本
.局部变量 GBK文本, 字节集
.局部变量 URL码, 文本型
.局部变量 n, 整数型
 
GBK文本 = 到字节集 (文本)
.计次循环首 (取字节集长度 (GBK文本), n)
    URL码 = URL码 + "%" + 取十六进制文本 (GBK文本 [n])
 
.计次循环尾 ()
返回 (URL码)
 
 
.子程序 UTF8编码转换, 文本型, 公开, 将一个UTF8编码的文本转换为URL编码,返回一个URL编码
.参数 文本, 文本型, , 需要转换为URL编码的UTF8编码的文本
.局部变量 URL码, 文本型
.局部变量 n, 整数型
.局部变量 UTF8文本, 字节集
 
UTF8文本 = 编码转换 (到字节集 (文本), #编码_GBK, #编码_UTF_8, )
.计次循环首 (取字节集长度 (UTF8文本), n)
    URL码 = URL码 + "%" + 取十六进制文本 (UTF8文本 [n])
 
.计次循环尾 ()
返回 (URL码)
 
.子程序 _分组框4_鼠标左键被按下, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型



工作时段:4008 808 898
其他时段:136 3658 2974